Feature Requests
Share ideas, discuss and vote on requests from other users in community
 

Fix Annoying Autocomplete / AutoFill across WHMCS Admin

myworksdesign shared this idea 1 year ago
Under Consideration

This topic has already unfortunately been broached on a smaller issue for the SMTP fields in settings, but there is an annoying issue across all of the WHMCS admin, where any browser will autofill / autocomplete the WHMCS admin (or any saved login info) login to any username/password fields in WHMCS. This is extremely annoying in the following cases, to name a few.

- Editing / Viewing a client Profile

- Editing / Viewing custom support ticket fields that contain a username/password field

- Editing / Viewing custom module options that contain a username/password

- Editing / Viewing WHMCS General Settings > SMTP settings

- And many more scenarios.

This can be resolved very easily by either adding a hidden username/password field to the top of the page code to trap this browser autocomplete/autofill or using the autocomplete="off" css setting in the fields above.

This is a very simple fix that will save 100% of WHMCS users grief every day.

Comments (11)

photo
1

This is so annoying, a super simple fix would be awesome here.

photo
1

Since autocomplete=off turned out to be insufficient for Firefox, I figured out another way to get rid of this

annoying behaviour.

Apache's mod_substitute (https://httpd.apache.org/docs/2.4/mod/mod_substitute.html) can be used to change test/password field type to 'hidden'.

Here are the directives for 6.1.1 (remove line breaks if this website inserts them):

Substitute 's|<tr><td class="fieldlabel">SMTP Username</td><td class="fieldarea"><input type="text" name="smtpusername" size="35" value=""></td></tr>|<tr><td class="fieldlabel">SMTP Username</td><td class="fieldarea"><input type="hidden" name="smtpusername" size="35" value=""></td></tr>|n'

Substitute 's|<tr><td class="fieldlabel">SMTP Password</td><td class="fieldarea"><input type="password" name="smtppassword" size="20" value=""></td></tr>|<tr><td class="fieldlabel">SMTP Password</td><td class="fieldarea"><input type="hidden" name="smtppassword" size="20" value=""></td></tr>|n'

Have fun,

b.

photo
1

Yes! This is SORELY needed.

photo
1

Yes please fix this. For me the most annoying place is the Yubikey 2 factor field on login.

photo
1

vote on this, especially on lastpass, it keeps getting autofill on user/password and very dangerous to cause access lost because user/pass would get overwritten

photo
1

Please fix this ASAP!

photo
1

OMG!!! Thank you for this comment!!!

It made me realise that it was lastpass autofilling much more than just Email and Password (which is weird as that's all the info it should keep). Name Fields and Description (eg Support Departments) were being autofilled.

Once you Edit the LastPass Advanced Settings for the site and check "Disable Autofill" then WHMCS works fine.

I was completely losing my mind and wanted to abandon WHMCS but in the end it was LastPass and a simple fix :)

Thank you! Thank you! Thank you!

photo
1

Glad to hear it :)

photo
1

@myworksdesign this entire requests section is full of things that drive away clients when things have been sitting for many years with no comment or progress from @whmcs.

photo
photo
1

Password for the SMTP should not be autofill EVER!

Having invoices not go out is a huge lass of business.

photo
1

I agree on this as well. Also have the problem in Safari, when looking a client, the search box gets auto filled with my login username, so it finds client matching my name and pops out a list of them, cover the client info and some tabs. Very annoying.